Several customers have reported that after changing a column type from single valued to multi valued, it still acts as single valued in our Ontolica drilldown controls.
This is a known SharePoint usability issue which is not related to Ontolica in any way.
Thankfully there is a method to fix it. This guide outlines the problem and the step by step solution.
Cause of problem
We have confirmed that this is a problem in MOSS. Not Ontolica. The root of the problem is that MOSS cannot change the crawled property of a column from single-valued to multi-valued as long as it exists in the MOSS search index. Of course you would expect MOSS to pick up on the change from single to multi value when doing a crawl, but MOSS consistently fails do so.
When a property (in this case a column type) has been indexed a crawled property is created. The definition of this crawled property cannot be changed. An example of such a change is when the list owner changes a column type from single to multi valued.
This might cause some confusion as the list column visually acts as a multi value type and can store multiple values as expected. The search index however does not pick up this change and only the last value of the multi value entry is actually indexed for the crawled property of this column type.
Ontolica can only see this crawled property as single valued since this is what the search index contains.
Solution (short version)
- On the crawled properties view, you click the property and uncheck the "include in search index" box and remove all mappings to managed properties.
- Then on the crawled properties view you click the "Edit category" button and check the "Delete all unmapped crawled properties" box (This removes the property from the list).
- Click the "Reset all crawled content" link on the leftpane.
- Do a full crawl. This will bring back the crawled property.
- Go to the crawled properties view and restore any mappings to managed properties you might have removed.
Now the property will correctly show up as being multi-valued in the crawled properties view.
Solution (long illustrated step by step version)
The solution is obviously to force the crawled property to be deleted from the index. This allows MOSS to create it again during the next crawl.
SharePoint does have a procedure for doing so but it is not intuitive to all Farm Administrators.
We have the following solution/workaround for your problem:
- Click on the link to your Shared Service Provider website. In this example “SharedServices1”.

- Click on “Search administration”.

- Click on “Metadata properties”.

- Click on “Crawled properties”.

- Click on “SharePoint”.

- Click on the crawled property for the relevant column type if the “Multi-valued” field is incorrect.

- Remove all mappings. Uncheck the “Include in search index” checkbox. Click OK.

- Back at the crawled properties view; click the “Edit Category” button.

- Check “Delete all unmapped crawled properties” checkbox. Click OK.

- Now the crawled property for the single valued column is removed.

- Click on “Reset all crawled content”.

- Click on “Reset now” and press OK in the Message box.

- Back on the Search Administration page click “Content sources”.

- Start and wait for full crawl to complete on all content sources. Click on “Metadata properties”.

- Click on “Crawled properties”.

- Click on “SharePoint”.

- The “Multi-valued” field is now updated on the crawled property for the relevant column.

Best regards
SurfRay - Department of Research & Development.


